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1A] Create a simple sequence based project. 
 

1.​ Create a blank project and, on the Design tab, in the File group, select New > Sequence. 
The New Diagram window is displayed. 

 
[Note: You can also add a Sequence activity to the Designer panel to create a new sequence.] 
 

2.​ In the Name field type a name for the automation, such as "First Sequence," and click 
Create. The Designer panel is updated accordingly. 

3.​ Create three String variables such as strFirstName, strLastName, and strHairColor, so 
that you can store data from the user in them. Leave the Default field empty, to indicate 
that there is no default value. 

 

 
4.​ Drag three Input Dialog activities to the Designer panel, one under the other. 

 
5.​ Select the first Input Dialog and, in the Properties panel, add a Label asking for the first 

name of the user, and a custom Title. 
 

 
6.​ In the Result field add the strFirstName variable. This indicates that this variable is going 

to be updated with the value added by the user at this point. 
 

7.​ Repeat steps 6 - 7 for the second and third Input Dialog activities to ask the user for his 
last name and hair color, and store them in the strLastName and strHairColor variables. 

 
 

8.​ Add a Message Box activity under the third Input Dialog. 
 

9.​ Select the Message Box and, in the Properties panel, in the Text field, add the variables 
and a string to enable you to display all information gathered from the user, such as: 
strFirstName + " " + strLastName + " has " + strHairColor + " hair." 
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10.​On the Design tab, in the File group, click Run. The automation is executed. The final 
output message should look as in the following screenshot. 

 

 
 
 
Conclusion : Thus we have studied to create a simple sequence based project. 
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1B] Create a flowchart-based project. 

1. Open UiPath Studio and create a new Blank Process named "FirstFlowchart". 

2. Open Main.xaml, drag a Flowchart activity into the Designer panel. 

3. Create three String variables: strFirstName, strLastName, and strHairColor. 

 

4. Drag three Input Dialog activities into the Flowchart to collect first name, last name, and hair color. 

 

[Like this create for last name and haircolor] 

5.  Set Labels and Titles in each Input Dialog and store results in the corresponding variables. 
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6. Add a Message Box activity and set the text to strFirstName + " " + strLastName + " has " + 
strHairColor + " hair." 

 

7. Connect all activities in sequence inside the Flowchart from Start to Message Box. 

 

8.  Click Run to execute the project and view the output. 

 

 
Conclusion : Thus we have studied to  create  a flowchart-based project. 
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1C] Automate UiPath Number Calculation (Subtraction, Multiplication, Division of numbers). 

1.​ Open UiPath Studio and create a new Blank Process named "NumberCalculation". 

2.​ Open Main.xaml, drag a Flowchart or Sequence activity into the Designer panel. 

3.​ Create four variables: num1 (Double), num2 (Double), subResult (Double), mulResult (Double), 
divResult (Double). 

 

4.​ Add two Input Dialog activities to get num1 and num2 from the user as strings. 
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5.​ Use Assign activities to convert inputs to Double using CDbl() (e.g., num1 = CDbl(strNum1)). 

 

6.​ Add three Assign activities to calculate subResult = num1 - num2, mulResult = num1 * num2, 
divResult = num1 / num2. 

 

7.​ Add a Message Box to display all results: "Subtraction: " + subResult.ToString + vbNewLine + 
"Multiplication: " + mulResult.ToString + vbNewLine + "Division: " + divResult.ToString 

 

8.​ Click Run to execute and test with any numbers. 
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Conclusion : Thus we have studied how to create a Automate UiPath Number Calculation. 
 

1D] Create an automation UiPath project using different types of variables (number, datetime, 
Boolean, generic, array, data table)  

 
1. Number (Int32) 
Use an Assign activity to create myNumber = 10 (Type: Int32). 
 
 

 
 
 
2. DateTime 
Use an Assign activity to create myDate = Now (Type: DateTime). 
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3. Boolean 
Use an Assign activity to create isEligible = myNumber > 5 (Type: Boolean). 
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4. Generic Value 
Use an Assign activity to create myGeneric = "25" (Type: GenericValue). 
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5. Array: Use an Assign activity to create myArray = {"Apple", "Banana", "Cherry"} (Type: Array of 
String). 

 

6. DataTable: Use a Build Data Table activity to create myTable with columns (Name, Age) and rows, 
then loop it using For Each Row in DataTable and add a Write Line to display: "Name: " + 
row("Name").ToString + ", Age: " + row("Age").ToString. 
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Conclusion: Thus we have studied how to create an automation UiPath project using different types of 
variables 
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2A] Consider an array of names. We have to find out how many of them start with the 

letter "a". Create an automation where the number of names starting with "a" is. 

counted and the result is displayed. 

 

1.​ Create a new sequence in UiPath named CountNamesWithA. 

2.​ Add an Assign activity to define namesArray = {"alice", "bob", "amy", "Alex", 
"john", "Annie"}. 

3.​ Add another Assign activity to initialize countA = 0. 

 

 

 

 

 

 

4.​ Insert a For Each activity to loop through namesArray with TypeArgument set to 
String. 

5.​ Inside the loop, add an If activity with condition item.ToLower.StartsWith("a"). 

6.​ In the Then block, add an Assign: countA = countA + 1. 
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7.​ After the loop, add a Message Box: "Number of names starting with 'a': " & 
countA.ToString. 

 

8.​ Run the workflow to display the count result. 

 

 

Conclusion: Thus we have studied how to create an automation where the number of names 
starting with "a" is. counted and the result is displayed. 
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2B] Demonstrate switch statement with an example. 

1. Use an Input Dialog activity to let the user select from Admin;Guest;User and store it in 
the userRole (Type: String) variable. 

 

2. Add a Switch activity with Expression: userRole and set TypeArgument to String. 

 

3. Add cases: "Admin", "User", "Guest" and a Default case for unrecognized roles. 
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4. Inside each case, add a Write Line activity to show a message like 

"Welcome, Guest” 

 

 

Conclusion: Thus we have studied how to demonstrate switch statement with an example. 

 

2C] Create an automation To Print numbers from 1 to 10 with break after the writeline 

activity inside for each activity. 

 

1. Assign → numbers = Enumerable.Range(1, 10).ToArray (Type: Array of Int32) 

2. For Each → loop through numbers with loop variable num (TypeArgument: Int32) 

3. Write Line → num.ToString inside the loop 
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4. Break → Place immediately after Write Line to exit loop after printing the first number 

 

Conclusion: Thus we have studied how to create an automation To Print numbers from 1 to 
10 with break after the writeline activity inside for each activity. 

 

2D] Create an automation using Do..While Activity to print numbers from 5 to 1 

1.​ Create a new Process in UiPath Studio and name it appropriately. 
2.​ Drag a Sequence activity into the Main workflow to organize your actions. 
3.​ Create an Integer variable called counter and set its default value to 5. 
4.​ Drag a Do...While activity inside the Sequence to implement the loop. 
5.​ Inside the Do section, add a Write Line activity to display the current value of counter. 
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6.​ Below that, add an Assign activity to decrement the counter by 1 (i.e., counter = 
counter - 1). 

7.​ Set the Do...While condition to counter >= 1 to continue the loop until 1. 

 
 

8.​ Run the workflow to see the numbers 5 to 1 printed in the Output panel. 
 

 

Conclusion: Thus we have studied how to create an automation using Do..While Activity to 
print numbers from 5 to 1. 

 

2E] Create an automation using Delay Activity between two writeline activities to 

separate their execution by 5 seconds 

1.​ Create a new Process in UiPath Studio and open the Main.xaml. 
 

2.​ Drag a Sequence activity onto the Designer panel to structure the workflow. 
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3.​ Create an integer variable named counter and initialize it to 5. 
 
 

4.​ Drag a Do While activity inside the sequence to perform the countdown. 

 

5.​ Inside the Do While Body, first add a Delay activity and set Duration to 00:00:01 (1 
second pause). 

 

6.​ Below Delay, add a Write Line activity with counter.ToString to print the current 
number. 

 

7.​ Add an Assign activity below the Write Line to update the counter: counter = counter 
- 1. 

 

8.​ Set the Do While condition to counter >= 1 to repeat until counter drops below 1. 

 

 

9.​ Run the workflow, and it will print numbers from 5 to 1 with a 1-second 
delay between each. 
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Conclusion: Thus we have studied how to create an automation using Delay Activity 
between two writeline activities to separate their execution by 5 seconds 

 

 

2F] Create an automation to demonstrate use of decision statements (if) 

1.​ Use Input Dialog → Ask user to enter their age in a Text Box and store it in Agelimit 
(Type: String) 

 

 
2.​ Use If activity → Condition: Integer.Parse(Agelimit) > 18 

3. In Then block → Add Message Box: "You can Drive!" 

4. In Else block → Add Message Box: "You cannot drive!"  
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5. Output: 

  

Conclusion: Thus we have studied how to create an automation to demonstrate use of 
decision statements (if) 
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3A] Basic Recording using Notepad 
 

1.​ Launch UiPath Studio and create a new Process project named 
BasicRecordingNotepad. 

 
2.​ Open Main.xaml and go to Record → Basic from the top toolbar. 

 
3.​ In the recorder window, click Open Application and select notepad.exe. 

 
4.​ Click inside the Notepad window and use Type to enter your message. 

 

 
5.​ Click Save & Exit to add the recorded actions to the workflow. 
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6.​ Press Run to see Notepad open and your text typed automatically. 
 

 
Conclusion: Thus we have studied how to create basic Recording using Notepad. 
 
3B] Basic Recording using G-Mail 
 

1.​ Use Recorder to open Gmail in Chrome at https://mail.google.com/mail/u/0/#inbox. 
 

2.​ Recorder step: Click "Compose" to start a new email. 
 

3.​ Recorder step: Type chinmay3244.cd@gmail.com into the To field. 
 

4.​ Recorder step: Type "Welcome to Email !" in the email body area. 
 

5.​ Recorder step: Click "Send" to send the email. 
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4A] Automate the process to extract data from an excel file into a data table and vice 
versa Create a new Sequence in your Main workflow. 

1.​ Drag a Use Excel File activity and set the path to input.xlsx. 
2.​ Inside it, add a Read Range activity and save the output to a variable dtData. 
3.​ Drag another Use Excel File activity and set the path to output.xlsx. 
4.​ Inside it, add a Write Range activity and pass dtData as the DataTable input. 
5.​ Set the target sheet name (e.g., "Sheet1") and tick the Add Headers option. 
6.​ Run the workflow to read data from input.xlsx and write it to output.xlsx. 

First Part: 
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Vice Versa Part: 
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Conclusion: Thus we have studied how to automate the process to extract data from an excel 
file into a data table and vice versa Create a new Sequence in your Main workflow. 

 

4B] Create an automation To Write data to specific cell of an excel sheet. 

1.​ Drag Use Excel File activity and select the Excel file path (testing.xlsx). 
2.​ Inside it, add a Write Cell activity. 
3.​ Set What to Write as "College". 
4.​ Set Where to Write as Excel.Sheet("SheetName").Cell("H4") or 

Excel.SelectedSheet.Cell("H4"). 
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5.​ Run the workflow to write "College" into cell H4 in Excel. 

 

Conclusion: Thus we have studied how to create an automation To Write data to specific cell 
of an excel sheet. 

4C] Create an automation To Read data to specific cell of an excel sheet. 

1.​ Drag and drop a Use Excel File activity and choose your Excel file. 
2.​ Inside it, add a Read Cell activity. 
3.​ Set Cell to read as Excel.Sheet("SheetName").Cell("A2") or 

Excel.SelectedSheet.Cell("A8"). 
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4.​ Assign the output to a variable (e.g., cellValue). 
5.​ (Optional) Use a Message Box or Write Line to display cellValue. 

 

 

Conclusion: Thus we have studied how to create an automation To Read data to specific cell 
of an excel sheet. 
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4D] Create an automation To append data to specific cell of an excel sheet. 

1.​ Use "Excel Application Scope" – Open the target Excel file by providing its path. 
 

2.​  Inside the scope, add "Write Cell" activity – This will allow writing directly to a 
specific cell. 
 

3.​ Set "SheetName" in Write Cell – Enter the name of the worksheet (e.g., "Sheet1"). 
 

4.​ Set "Cell" property – Provide the cell address where you want to append data (e.g., 
"C5"). 
 

5.​ Set "Value" property – Type the data or use a variable to write into that specific cell. 

 
6.​ Save and run the workflow – This will append/write the data to the desired cell in 

Excel. 
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Conclusion: Thus we have studied how create an automation To append data to specific cell 
of an excel sheet. 

 

 

 

4E] Create an automation To sort a table of an excel sheet. 

1.​ Use "Excel Application Scope" – Open the Excel file containing the table to be 
sorted. 

2.​ Use "Sort Table" activity – Drag this inside the scope to perform sorting. 
3.​ Set "SheetName" – Enter the worksheet name (e.g., "Sheet1"). 
4.​ Set "Table Name" – Provide the exact table name (e.g., "Table1"). 
5.​ Configure "Sort Fields" – Add column names and sort order (e.g., {"Rollno", 

"Ascending"}). 
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6.​ Run the automation – The table will be sorted as per your settings. 

Before sort:                                    After Sort: 

        

 

Conclusion: Thus we have studied how to create an automation To sort a table of an excel 
sheet. 

4F] Create an automation To filter a table of an excel sheet. 

1.Use Use Excel File and select your Excel file. 

2. Inside it, add Filter Excel activity. 

3.Set the Source (e.g. Excel.Sheet("Sheet1")). 

4. Filter By, choose the Column Name (e.g. "Location"). 
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5.Set the Filter Condition (e.g. equals "Pen"). 

Before filter :                                                           After filter: 

  

Conclusion: Thus we have studied how to create an automation To filter a table of an excel 
sheet. 
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A] Implement the attach window activity, Automate using Anchor Base, Automate using 
Element Exists. 
1. Open Browser – Launch Google Chrome and navigate to the given URL. 

2. Check App State – Verify if the "Images" tab element is present on the page. 

3. If Target Appears – Show message box: "Target has appeared". 

4. If Target Does Not Appear – Show message box: "Target did not appear". 
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A]​ Demonstrate the following activities in UiPath: 

i)​ Mouse (click, double click and hover) 

1.​ Open UiPath Studio and create a new Process. 
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2.​ Add a Sequence inside the Main workflow. 

3.​ Use Application/Browser activity and set application path as 
C:\Windows\System32\notepad.exe. 

​  

4.​ Inside the Do container, add a Type Into activity and indicate the 
text area of Notepad. 

5.​ Type the text "Hello UI Path! This is demo for Click, Double 
Click, and Hover". 

​  

6.​ Add a Click activity and indicate the File menu in Notepad, set 
click type to Single and mouse button to Left. 
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​  

7.​ Add another Click activity and indicate the Maximize button of 
Notepad, set click type to Double and mouse button to Left. 

​  

8.​ Add a Hover activity and indicate the Close button of Notepad. 

​  

 

Output: 
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ii)​ Type into 

1.​ Open UiPath Studio and create a new Process. 

2.​ Add a Sequence inside the Main workflow. 

3.​ Use Application/Browser activity and set application path as 
C:\Windows\System32\notepad.exe. 
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​  

4.​ Inside the Do container, add a Type Into activity and indicate 
the text area of Notepad. 

5.​ Type the text "Hello UI Path! This is demo for Click, Double 
Click, and Hover". 

​  

 

Output: 
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Conclusion: Thus we have studied to demonstrate Mouse Events and 
Type into activity in UiPath. 

 

 

 

B]​ Demonstrate the following Events in UiPath: 

i)​ Element triggering event 

1.​  Open UiPath and create a new Process. 

2.​  Drag and drop Trigger Scope activity into the sequence. 

3.​  Inside Trigger Scope → add Click Trigger activity. 

4.​  Indicate the Notepad text area (or any clickable area inside 
Notepad) as the target element. 

5.​  Select Mouse Button as BTN_LEFT. 
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6.​  Go to Actions panel → add a Sequence. 

7.​  Inside the Sequence → drag Use Application/Browser activity and 
select Notepad  (C:\Windows\System32\notepad.exe). 

​  

8.​  Inside Do block → add Type Into activity. 

9.​  Indicate the text area of Notepad. 

10.​ Enter text → "Hello UI Path". 
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​  

11.​ After that, add a Message Box activity. 

12.​ Enter text → "Click Event Triggered". 

​  

13.​ Run the workflow → when you click in Notepad (on the selected 
element), text will be typed and the message box will appear. 

Output: 

 

ii)​ Image triggering event 

1.​ Open UiPath and create a new Process. 

2.​ Drag and drop Trigger Scope activity into the sequence. 
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3.​ Inside Trigger Scope → add Click Image Trigger activity. 

4.​ Indicate the image on screen (e.g., the picture shown in your 
workflow). 

5.​ Select Mouse Button as BTN_LEFT. 

​

 

6.​ Go to Actions panel → add a Sequence. 

7.​ Inside the Sequence → add a Message Box. 

8.​ Enter text → "Image Triggered". 
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9.​ Run the workflow → when the image is clicked, the trigger fires 
and shows the message. 

Output: 

 

 

iii) System Triggering Event 

1.​ Open UiPath and create a new Process. 

2.​ Drag and drop Trigger Scope activity into the sequence. 

3.​ Inside Trigger Scope → add System Trigger activity. 

4.​ Set TriggerInput → select both Keyboard and Mouse. 

​

 

5.​ Go to Actions panel → add a Sequence. 
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6.​ Inside the Sequence → drag Use Application/Browser activity and 
select Notepad (C:\Windows\System32\notepad.exe). 

 

7.​ Inside Do block → add Type Into activity. 

8.​ Indicate editable text area in Notepad. 

9.​ Enter text → "Hello Swayam". 
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​  

10.​ After that, add a Message Box. 

11.​ Enter text → "System Triggered". 

 

12.​ Run the workflow → when keyboard/mouse input happens, 
Notepad opens, types text, and message box appears. 

Output: 

 

 

 

 

Conclusion: Thus we have studied to demonstrate triggerring events in 
UiPath 

 

Robotic Process Automation 



 

Practical No. 7 
Screen Scraping and Web Scraping methods 

 

 

 

 

 

 

 

 

 

 

 

 

 

​ ​ ​ ​ ​ ​ ​ ​  

 

Name: Neeraj Sanjay Shah 

Class: T.Y. BSc. DS 

Roll no: 50 

Subject: RPA 

Sign: 

A]​ Automate the following screen scraping method using UiPath: 

i)​ Full Text  

Steps:  
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1.​ Use Open Browser to navigate to Amazon Electronics page. 
2.​ Add Get Text activity and indicate the element (“Electronics”). 
3.​ Save the output to a variable (scrapdata). 
4.​ Use Message Box to display scrapdata.ToString. 

 
Output:  

 

Conclusion: Thus we have studied to demonstrate Full Text method in 
UiPath 

 

 

B)​ Demonstrate Data Scraping and display values in Message box    
using OCR. 
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Steps: 

1.​ Open UiPath Studio and create a new process. 

2.​ Drag and drop the Use Application/Browser activity and select 
Chrome browser. 

3.​ In the Browser URL property, enter chrome://newtab/. 

4.​ Inside the Do container, add a Get OCR Text activity. 

5.​ Indicate the target area in the Chrome window where you want to 
scrape text. 

6.​ Select Tesseract OCR Engine as the OCR method. 

 

7.​ Create a variable (e.g., variable1) to store the extracted text output. 
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8.​ After the OCR activity, add a Message Box activity. 

9.​ In the Text property of the Message Box, pass the variable name 
with .ToString. 

 

10.​Run the workflow → it will scrape text from the browser and 
display it in the message box. 

Output: 

 

Conclusion: Thus we have studied to demonstrate Data Scraping Using 
OCR in UiPath. 
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A]​ Read Pdf with OCR. 

Steps: 

1.​ Open UiPath Studio and create a new process. 
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2.​  Drag and drop the Read PDF with OCR activity into the workflow. 

3.​ In the File Name property, provide the path of the PDF file (e.g., 
"C:\Users\Admin\Desktop\Offer Letter.pdf"). 

4.​  Select Tesseract OCR as the OCR engine to extract text. 

​  

5.​  Create a variable (e.g., scrap_data) to store the extracted text. 

 

6.​  After the OCR activity, add a Message Box activity. 

7.​  In the Text property of the Message Box, write 
scrap_data.ToString. 

​  

8.​ Run the workflow: UiPath will read the PDF file using OCR and 
display the extracted text in a message box. 

 

 

Output: 
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Conclusion: Thus we have studied to demonstrate Read Pdf with OCR 
Activity in UiPath 

 

 

 

 

 

B]​ Demonstrate Exception Handling Using UiPath 

Robotic Process Automation 



Neeraj Shah​ T.Y.BSc.DS​ Roll no:50 

Steps: 

1.​ Open UiPath Studio and create a new process. 

2.​ Create a variable named “Array” of type Int32[] and assign default 
value {10, 20}. 

3.​ Create another variable named “i” of type Int32 and assign default 
value -1. 

4.​ Drag and drop a Sequence activity into the workflow. 

5.​ Insert a Try Catch activity inside the sequence. 

6.​ In the Try block, add a Message Box with text Array(i).ToString. 

 

7.​ In the Catch block, set exception type as: 
System.IndexOutOfRangeException. 

8.​ Add a Message Box in the Catch block with text:  
Exception.ToString. 
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9.​ In the Finally block, add a Message Box with text "Exception 
Handled". 

 

10.​Run the workflow to see exception handling execution. 

Output: 

 

Conclusion: Thus we have studied to demonstrate Exception Handling 
Using UiPath. 
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A] Demonstrate Email Automation to Configure and Read Email, 
Send Email with Attachments, Reply to Email. 

Steps: 
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1.​ Open UiPath Studio and create a new Process. 

2.​ Drag Use Gmail activity into the Designer panel. 

3.​ In Account, enter your Gmail ID (e.g., 
swayamban132@gmail.com). 

 

4.​ Inside Do container of Use Gmail, drag a Send Email activity. 

5.​ In the Account field of Send Email, select Gmail. 

6.​ In the To field, enter recipient’s email (e.g., 
swayamjb23hds@student.mes.ac.in). 

7.​ Enter a Subject as "This is sample mail with attachment for email 
automation". 

8.​ Select Body type as HTML, then provide body text (if required). 

9.​ Add Attachments by browsing file paths 
(e.g.,"C:\Users\Admin\Desktop\NewFile.txt") 

​  

10.​ After Send Email, drag a For Each Email activity. 
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11.​ In “In emails from”, select Gmail.Folder("Inbox"). 

12.​ Set limit to first 5 emails and check Unread mail and Retrieve   
attachments options. 

13.​ The variable CurrentMail will get automatically created in the for 
each activity. 

 

14.​ Inside the loop, drag a Message Box activity. 

15.​ In Message Box, set Text as CurrentMail.Body to display email  
body. 

​  

16.​ After Message Box, drag a Reply To Email activity. 

17.​ In Email, select CurrentMail. 

18.​ In Add To recipients, enter recipient’s email (e.g., 
swayamjb23hds@student.mes.ac.in). 

19.​ Set New subject as "Email Automation". 

20.​ In Body, select HTML and enter message "Thank You so much i 
got the email". 
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21.​ Save the project and run the automation. 

Output: 

Send mail with attachment: 

 

 

 

Read an Email: 
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Reply to Email: 
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